Interested in Advertising on 780Tuners?  Please contact us

Results 1 to 6 of 6

Thread: Z32 Fuel Pump Issue?

  1. #1

    Default Z32 Fuel Pump Issue?

    Car drove fine the night before without any problem but the next day it would not start.
    Cranks but would not start. Tried it a few times and no go.

    One thing I noticed is i could not hear the fuel pump priming. So I checked my fuel line pressure gauge and no pressure.
    I checked the FCPU and it was bypassed already.

    Now is this a fuel pump issue? Is there a way to bench test a fuel pump to find out if it's the issue? Or could it be an ECU issue?

    Any help in the right direction is appreciated.


  2. #2


    Check Ecu for codes, check fuel pressure after the filter, check for spark, check and clean ptu/cas connections.

  3. #3


    Checked ECU Code 55 All Clear
    No fuel pressure after filter
    PTU/CAS connections all clean and snug

    Have not tried the spark test just yet...

  4. #4


    No fuel pressure in the on position. I would check for power at the fuel pump. If 12v, then fuel pump is the problem. If no 12 v, then back track at the relays.

  5. #5


    Also check your fuel pump link by the battery, under the black cover in front of the battery, closest one to the engine marked Fuel Pump Eng Inj:

  6. #6


    Finally had time to check voltage at the pump.
    Yes I do have 13.4 at the fuel pump connector but pump won't prime.
    I guess my fuel pump took a dump.
    Now I should probably get a new one... I'm guessing a Walbro 485 would suffice? And leave the FPCU bypassed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts